Resolved
This issue has been resolved. We are no longer observing any impact to Capitec Pay transactions with performance returning to normal.
Monitoring
We are seeing improved performance across Capitec Pay transactions and are continuing to monitor to ensure stability.
Investigating
Capitec is currently experiencing degraded performance. Users transacting via Capitec Pay may experience slow response times or intermittent errors.
Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other payment methods remain fully operational.