Resolved
The degraded performance affecting payment processing on the Stitch Express Shopify Subscriptions app has been resolved.
All systems are operating normally.
Investigating
We're aware that users of the Stitch Express Shopify subscriptions app are currently experiencing degraded performance which may affect payment processing.
We're actively investigating the issue. Please monitor this page for any status updates.